TSHOOT – Redistribution Part 1 – Configuring an OSPF / EIGRP / iBGP Lab to completion, ready for Redistribution!

Redis_Base_3

While getting together some command prompt syntax from my lab, I got a jolt of nostalgia from labbing ROUTE, and decided to instead configure the lab Topology shown above as I started configuring my switches for Layer 3 routing and before I knew it I was troubleshooting OSPF and EIGRP Ajdacencies!

I will try to get the lab to a place where Redistribution can be labbed in another article solely to cut down on the posts filled with labbing output, however my next post will be the theory sandwiched between labbing articles, so before I am redistributing routes into other routing domains I know all the different ways to accomplish it (and what to troubleshoot when things go wrong)!

The beginning of the Route Redistribution Lab

I’m using my 3750 physical switches with ‘ip routing’ enabled and ‘no switchport’ on connected interfaces to simulate the following Layer 3 Topology:

Redis_Base

I will be removing the “Route Table Codes” in show commands, will post it once at the top here for reference, so it will not be in my “show” commands going forward:

Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP
+ – replicated route, % – next hop override

Highlighted in red are all the routes I expect to see, I am not sure if I will hook up a 4th router to create an NSSA to demonstrate N1 and N2 routes as I already have a lab / decent grasp on that, and I need to make some serious forward progress on the don’t knows before TSHOOT day!

Current configs of all routers to make sure we are good before getting started:

R1

R1#sh ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.12.0/30 is directly connected, FastEthernet1/0/1
L 10.1.12.1/32 is directly connected, FastEthernet1/0/1
C 10.1.13.0/30 is directly connected, FastEthernet1/0/3
L 10.1.13.1/32 is directly connected, FastEthernet1/0/3
11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 11.11.11.0/24 is directly connected, Loopback1
L 11.11.11.1/32 is directly connected, Loopback1
R1#

R2

R2#sh ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.12.0/30 is directly connected, FastEthernet1/0/1
L 10.1.12.2/32 is directly connected, FastEthernet1/0/1
C 10.1.23.0/30 is directly connected, FastEthernet1/0/2
L 10.1.23.1/32 is directly connected, FastEthernet1/0/2
22.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 22.22.22.0/24 is directly connected, Loopback2
L 22.22.22.2/32 is directly connected, Loopback2
R2#

R3

R3#sh ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.13.0/30 is directly connected, FastEthernet1/0/3
L 10.1.13.2/32 is directly connected, FastEthernet1/0/3
C 10.1.23.0/30 is directly connected, FastEthernet1/0/2
L 10.1.23.2/32 is directly connected, FastEthernet1/0/2
33.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 33.33.33.0/24 is directly connected, Loopback3
L 33.33.33.3/32 is directly connected, Loopback3
R3#

At this point no routes are configured, only interfaces configured as Layer 3 Point-to-Point connections, along with the discontiguous loopback interfaces on each router.

I did initially configure RIPv2 on the 10.1.23.0/30 network between R2 and R3, but being that I just do not see it in production networks at all (and I see a lot of them), I decided time would be better spent labbing up iBGP and getting into BGP in general as that is the last monster topic to really tackle once more for the CCNP R/S Certification ūüôā

This is the Topology that I believe will give each router one dynamic route:

Redis_Base_3

These protocols should cover most of TSHOOT with the exception of IPv6, but if that is anything like the Routing Protocols themselves, the differences will be minimal and covered at very least in detail in the Redistribution theory discussion.

For some reason I have always been a fan of peering iBGP with loopback interfaces and static routes pointing to them, so that is the deal with the configs on R2 and R3.

Without further ado, configuration time!

R1 OSPF and EIGRP config

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#network 10.1.12.0 0.0.0.3 area 0
R1(config-router)#exit
R1(config)#router eigrp 100
R1(config-router)#no auto
R1(config-router)#network 10.1.13.0 0.0.0.3
R1(config-router)#network 11.11.11.0 0.0.0.255
R1(config-router)#^Z
R1#

R2 OSPF and iBGP config

R2(config)#router ospf 1
R2(config-router)#network 10.1.12.0 0.0.0.3 area 0
R2(config-router)#network 22.22.22.0 0.0.0.255 area 22
R2(config-router)#network 22.22.22.0 0.0.0.255 area 22
R2(config-router)#exit
R2(config)#ip route 3.3.3.3 255.255.255.255 10.1.23.2
R2(config)#router bgp 100
R2(config-router)#neighbor 3.3.3.3 remote-as 100
R2(config-router)#neighbor 3.3.3.3 update-source lo22
R2(config-router)#network 10.1.23.0 mask 255.255.255.0
R2(config-router)#^Z
R2#

R3 EIGRP and iBGP configuration

R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#no auto
R3(config-router)#network 10.1.13.0 0.0.0.3
R3(config-router)#exit
R3(config)#ip route 2.2.2.2 255.255.255.255 10.1.23.1
R3(config)#router bgp 100
R3(config-router)#neighbor 2.2.2.2 remote-as 100
*Mar 1 03:26:11.720: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up
R3(config-router)#neighbor 2.2.2.2 update-source lo33
R3(config-router)#network 33.33.33.0 mask 255.255.255.0
R3(config-router)#network 10.1.23.0 mask 255.255.255.0
R3(config-router)#^Z
R3#

We have a BGP Adjacency!

Before I get too cocky let take a look at all 3 IP Route Tables, as my goal was to have at least 1 unique Dynamically learned route per Router by the end of this setup:

R1

R1#sh ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.12.0/30 is directly connected, FastEthernet1/0/1
L 10.1.12.1/32 is directly connected, FastEthernet1/0/1
C 10.1.13.0/30 is directly connected, FastEthernet1/0/3
L 10.1.13.1/32 is directly connected, FastEthernet1/0/3
11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 11.11.11.0/24 is directly connected, Loopback1
L 11.11.11.1/32 is directly connected, Loopback1
22.0.0.0/32 is subnetted, 1 subnets
O IA 22.22.22.2 [110/2] via 10.1.12.2, 01:05:49, FastEthernet1/0/1
R1#

OSPF!

R2

R2#sh ip route

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback22
3.0.0.0/32 is subnetted, 1 subnets
S 3.3.3.3 [1/0] via 10.1.23.2
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.12.0/30 is directly connected, FastEthernet1/0/1
L 10.1.12.2/32 is directly connected, FastEthernet1/0/1
C 10.1.23.0/30 is directly connected, FastEthernet1/0/2
L 10.1.23.1/32 is directly connected, FastEthernet1/0/2
22.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 22.22.22.0/24 is directly connected, Loopback2
L 22.22.22.2/32 is directly connected, Loopback2
33.0.0.0/24 is subnetted, 1 subnets
B 33.33.33.0 [200/0] via 3.3.3.3, 00:19:45
R2#

BGP (and Static for BGP Peering)!

R3#sh ip route

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets
S 2.2.2.2 [1/0] via 10.1.23.1
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback33
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.13.0/30 is directly connected, FastEthernet1/0/3
L 10.1.13.2/32 is directly connected, FastEthernet1/0/3
C 10.1.23.0/30 is directly connected, FastEthernet1/0/2
L 10.1.23.2/32 is directly connected, FastEthernet1/0/2
11.0.0.0/24 is subnetted, 1 subnets
D 11.11.11.0 [90/156160] via 10.1.13.1, 00:23:33, FastEthernet1/0/3
33.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 33.33.33.0/24 is directly connected, Loopback3
L 33.33.33.3/32 is directly connected, Loopback3
R3#

EIGRP (and Static for BGP Peering)!

We do have Neighbor Adjacencies everywhere even though we don’t see routes

R1

R1#sh ip ospf nei

Neighbor ID     Pri           State       Dead Time     Address     Interface
     2.2.2.2            1           FULL/DR   00:00:33       10.1.12.2   FastEthernet1/0/1

R1#sh ip eigrp nei
EIGRP-IPv4 Neighbors for AS(100)
H       Address    Interface   Hold    Uptime        SRTT RTO   Q  Seq
0      10.1.13.2      Fa1/0/3         11        01:13:52          1     150     0    3
R1#

R2

R2#sh ip ospf nei

Neighbor ID    Pri        State               Dead Time   Address       Interface
1.1.1.1                  1       FULL/BDR         00:00:37      10.1.12.1     FastEthernet1/0/1

R2#sh ip bgp
BGP table version is 4, local router ID is 22.22.22.2
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i – IGP, e – EGP, ? – incomplete

Network           Next Hop        Metric    LocPrf Weight Path
*> 10.1.23.0/30     0.0.0.0                0                           32768     i
* i                            3.3.3.3                0             100            0         i
*>i33.33.33.0/24    3.3.3.3               0             100            0         i
R2#

Lots of Valid, Best, Internal routes for BGP!

R3

R3#sh ip eigrp nei
EIGRP-IPv4 Neighbors for AS(100)
H      Address    Interface   Hold   Uptime   SRTT  RTO   Q   Seq
0    10.1.13.1      Fa1/0/3           12      01:23:30    14        100   0     2

R3#sh ip bgp
BGP table version is 3, local router ID is 33.33.33.3
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i – IGP, e – EGP, ? – incomplete

Network             Next Hop  Metric LocPrf Weight Path
* i10.1.23.0/30      2.2.2.2          0         100          0           i
*>                            0.0.0.0          0                      32768      i
*> 33.33.33.0/24   0.0.0.0          0                      32768      i
R3#

I am going to leave it here for the Redistribution Lab for tonight

Getting this lab started up from scratch, breaking it a few times / figuring out behaviors, and ultimately getting to this point of configured is absolutely awesome from what I actually intended to do on the equipment (demonstrate a few redistribute commands).

Now that this is set up, I will go through the theory of what Route Redistribution is, then move on to Redistributing this configured lab to demonstrate those concepts.

This will lead into BGP, and I may just throw another router or two into this mix, so if looking for BGP Route Redistribution information this is the correct spot to be!

Almost to the summit ūüôā

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s