Before we dive into the CCNP material, just a real world note, I see most customers have edge devices with two static routes (one floating for failover with a slightly higher AD) and all corporate traffic has VPN tunnels configured back to the main office servers.
So to tie this now back to CCNP related materials, that is where you would configure this type of route, on the spokes / edge routers of a network, that don’t need to have all the main office networks Prefixes but just a general “send all your traffic to me” statement.
It’s basically the same places you’d make into stub networks, but Stubs have certain default behaviors you might not want impacting traffic, so a simple default route for EIGRP traffic would be all it needs.
That being said, if I were to configure this entire network I’d make R4 and R5 stubs, configure a default route on R1 to send down to its spokes, but since I’m not discussing Stub routers (covered in very previous post) I will discuss the 3 different ways of propagating a default-route through EIGRP now that we know the how and why!
First method: Using a static route with the “network” command and Redistribution
One really good to know thing about this, and I don’t know how I have not known about this previously, but you can configure a static route to Null0 to advertise the route, however with this type of default route means that anything not matched in the route table is going to be discarded per that default route on R1 – In the real world this would typically be your internet traffics ISP Gateway for the next hop (but in our lab its Null0):
R1(config)#ip route 0.0.0.0 0.0.0.0 null0
R1(config)#
This can be configured in EIGRP, but on R1 it will still show up in the IP route table as a Static route on R1 because it is considered directly connected so it has an Administrative Distance of 1, although to neighbors it will show as an EIGRP route with an AD of 90:
R1
R1(config)#router eigrp 100
R1(config-router)#network 0.0.0.0 0.0.0.0
R1(config-router)#exit
R1(config)#do sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S* 0.0.0.0/0 is directly connected, Null0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 172.12.123.2, 00:11:23, Serial0/0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 172.12.123.3, 00:11:23, Serial0/0/0
172.12.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.12.23.0/24 [90/2173416] via 172.12.123.3, 00:11:23, Serial0/0/0
[90/2173416] via 172.12.123.2, 00:11:23, Serial0/0/0
C 172.12.123.0/24 is directly connected, Serial0/0/0
L 172.12.123.1/32 is directly connected, Serial0/0/0
R1(config)#
R2
R2#sh ip route
Gateway of last resort is 172.12.123.1 to network 0.0.0.0
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 172.12.123.1, 00:00:26, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.23.3, 00:24:36, FastEthernet0/0
172.12.0.0/24 is subnetted, 2 subnets
C 172.12.23.0 is directly connected, FastEthernet0/0
C 172.12.123.0 is directly connected, Serial0/0
D* 0.0.0.0/0 [90/2169856] via 172.12.123.1, 00:00:27, Serial0/0
R2#
As can be seen it does what it needs to do, which is one of the ways a default route can be propagated, by using Null0 if there isn’t a specific next hop you want to use (Like an ISP Gateway as mentioned above).
Fun fact, you can also create a Null0 logical interface by type “int null0” and configure it, but it’d of course still send all traffic to a logical interface / logical trash can for traffic.
Also, you can also use a static route to propagate the default route simply by redistributing it into EIGRP:
R1(config)#router eigrp 100
R1(config-router)#redistribute static connected ?
% Unrecognized command
R1(config-router)#redistribute static ?
metric Metric for redistributed routes
route-map Route map reference
<cr>
R1(config-router)#redistribute static
R1(config-router)#
I left that error in there to demonstrate that in EIGRP, even if you use the other two commands it will not allow “subnets” to be be included on the command. So lets have a look at how it’s seen around the network now by none R1 routers (R1 see’s it the same):
R2#sh ip route
Gateway of last resort is 172.12.123.1 to network 0.0.0.0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.23.3, 00:47:10, FastEthernet0/0
172.12.0.0/24 is subnetted, 2 subnets
C 172.12.23.0 is directly connected, FastEthernet0/0
C 172.12.123.0 is directly connected, Serial0/0
D*EX 0.0.0.0/0 [170/2169856] via 172.12.123.1, 00:01:39, Serial0/0
R2#
So this is much less efficient for two reasons, the first being that it’s AD when from 90 to now 170 as it’s an External (Redistributed) EIGRP route to all neighbor routers, but also on R1 when a new Static route is added it will also be Redistribute as show here:
R1(config)#ip route 172.12.34.0 255.255.255.0 172.12.123.3
R1(config)#
ASR#2
[Resuming connection 2 to r2 … ]
R2#sh ip route eigrp
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.23.3, 00:52:04, FastEthernet0/0
172.12.0.0/24 is subnetted, 3 subnets
D EX 172.12.34.0 [170/2681856] via 172.12.123.1, 00:00:13, Serial0/0
D*EX 0.0.0.0/0 [170/2169856] via 172.12.123.1, 00:06:34, Serial0/0
R2#
So needless to say this is not ideal, unless your objective is to redistribute all static routes on exam day, but in the real world you probably don’t want new IP route statements accidentally being propagated throughout the EIGRP network.
Using the “network” command to propagate it is looking like the best way so far with static routes, as the AD of 170 as well leaves some room for another default route entered via “network” with an AD of 90 somewhere else could take it’s place as the default route for R2 (as well as redistributing all future static routes).
Using “ip default-network” command (Second way to propagate default routes)
This command can only be used in conjunction with a “Classful” network as the default route, so the best way to manipulate a classful network on the router sending out default routes, is to create a loopback interface with a classful network on it.
The very important things to note about this command:
- The network MUST be Classful for this command to work
- The network must be in your IP route table, whether its directly connected or added with the “ip route …” statement
- The command “ip default-network …” is NOT configured in EIGRP itself
So lets look at how it works on the equipment:
R1(config)#no ip route 0.0.0.0 0.0.0.0 null0
R1(config)#do clear ip route *
R1(config)#do sh ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, + – replicated route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 172.12.123.2, 00:00:08, Serial0/0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 172.12.123.3, 00:00:08, Serial0/0/0
* 11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C* 11.0.0.0/8 is directly connected, Loopback11
L 11.0.0.1/32 is directly connected, Loopback11
172.12.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.12.23.0/24 [90/2173416] via 172.12.123.3, 00:00:08, Serial0/0/0
[90/2173416] via 172.12.123.2, 00:00:08, Serial0/0/0
C 172.12.123.0/24 is directly connected, Serial0/0/0
L 172.12.123.1/32 is directly connected, Serial0/0/0
R1(config)#
So I left the code table in specifically to show that the new interface 11.0.0.0/8 is being flagged as a default candidate route, even though R1 does not have it in its own IP route table as a default route, also using a Class A network is ok in lab / exam environments but I’m sure its better to use a Class C as to avoid overlapping future addresses.
Now it is showing on here that it is our marked candidate default route, however for it to be transmitted to EIGRP neighbors, the network must also be added to EIGRP, no Wildcard mask needed as the network needs to be classful:
R2#sh ip route
Gateway of last resort is 172.12.123.1 to network 11.0.0.0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.23.3, 00:20:16, FastEthernet0/0
172.12.0.0/24 is subnetted, 2 subnets
C 172.12.23.0 is directly connected, FastEthernet0/0
C 172.12.123.0 is directly connected, Serial0/0
D* 11.0.0.0/8 [90/2297856] via 172.12.123.1, 00:00:09, Serial0/0
R2#
So now on R1 we can set an actual default route on the router advertising itself as a default route to all EIGRP neighbors, while being able to broadcast our router as the default route for neighbors, and here is a demonstration of this using a loopback interface as our ISP’s gateway address:
R1
R1(config)#int lo100
*May 15 03:48:33.147: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100, changed state to up
R1(config-if)#ip add 100.100.100.2 255.255.255.0
R1(config-if)#exit
R1(config)#do sh ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route, + – replicated route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 172.12.123.2, 00:31:36, Serial0/0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 172.12.123.3, 00:31:36, Serial0/0/0
* 11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C* 11.0.0.0/8 is directly connected, Loopback11
L 11.0.0.1/32 is directly connected, Loopback11
100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 100.100.100.0/24 is directly connected, Loopback100
L 100.100.100.2/32 is directly connected, Loopback100
172.12.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.12.23.0/24 [90/2173416] via 172.12.123.3, 00:31:36, Serial0/0/0
[90/2173416] via 172.12.123.2, 00:31:36, Serial0/0/0
C 172.12.123.0/24 is directly connected, Serial0/0/0
L 172.12.123.1/32 is directly connected, Serial0/0/0
R1(config)#
Note that 2.2.2.2 is learned via EIGRP, however our “ISP Gateway” loopback is a directly connected route not being advertised to R2.
R2
R2#sh ip route
Gateway of last resort is 172.12.123.1 to network 11.0.0.0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.23.3, 00:44:00, FastEthernet0/0
172.12.0.0/24 is subnetted, 2 subnets
C 172.12.23.0 is directly connected, FastEthernet0/0
C 172.12.123.0 is directly connected, Serial0/0
D* 11.0.0.0/8 [90/2297856] via 172.12.123.1, 00:23:53, Serial0/0
R2#ping 100.100.100.2 source 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.2, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms
R2#
So as can be seen, even though R2 has no idea what the internet address is that it is pinging to, it is able to establish 2-way Layer 3 communication to it because it has a default route to R1 that then has the connected “ISP Gateway” as it’s own default route, which on exam day might be another router address.
I hope it was clear that I defined the EIGRP discovered IP of 2.2.2.2 on R1 when pinging from R2, as the 172.12.123.0/24 network shows as directly connected on R1/R2/R3, however the loopbacks are only known via EIGRP.
So this for practical purposes is the best way to do it, as someone has to have a gateway to the internet, it can’t all be EIGRP networks and some networks have a single point of exit / entry for internet data (usually where heavy duty edge devices are to filter internet traffic).
So I am wondering, if this will pass along to R4, lets join it to EIGRP quick and see if R3 will continue to propagate on to the next neighbor:
Bringing up Adjacency and reviewing route tables:
R3:
R3(config)#router eigrp 100
R3(config-router)#network 172.12.34.0 0.0.0.255
R3(config-router)#
*Mar 31 22:59:17.586: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.34.4 (FastEthernet0/1) is up: new adjacency
R3(config-router)#
R4
*May 15 02:58:00.791: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 172.12.34.3 (FastEthernet0/1) is up: new adjacency
R4(config-router)#do sh ip route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/158720] via 172.12.34.3, 00:00:12, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.34.3, 00:00:12, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback4
D* 11.0.0.0/8 [90/2300416] via 172.12.34.3, 00:00:12, FastEthernet0/1
172.12.0.0/16 is variably subnetted, 4 subnets, 2 masks
D 172.12.23.0/24 [90/30720] via 172.12.34.3, 00:00:12, FastEthernet0/1
C 172.12.34.0/24 is directly connected, FastEthernet0/1
L 172.12.34.4/32 is directly connected, FastEthernet0/1
D 172.12.123.0/24
[90/2172416] via 172.12.34.3, 00:00:12, FastEthernet0/1
R4(config-router)#
Back to R3 to confirm it has the same route but a default gateway:
R3(config-router)#do sh ip route
Gateway of last resort is 172.12.123.1 to network 11.0.0.0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/156160] via 172.12.23.2, 02:05:01, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback3
172.12.0.0/24 is subnetted, 3 subnets
C 172.12.34.0 is directly connected, FastEthernet0/1
C 172.12.23.0 is directly connected, FastEthernet0/0
C 172.12.123.0 is directly connected, Serial0/2
D* 11.0.0.0/8 [90/2297856] via 172.12.123.1, 00:41:48, Serial0/2
R3(config-router)#
Back to R4 to confirm connectivity to our default route is toast:
R4(config-router)#do ping 100.100.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.2, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R4(config-router)#
This actually also happened to Keith Bogart on his video lesson for this, which was kind of funny as he wasn’t expecting this behavior and became a bit flustered with Cisco for having this kind of behavior happen, so I know it is not just my lab.
So even though this is the better join, keep in mind this is only good for routers one hop away, like Query packets being sent from an EIGRP router with advertising Summary routes, it will only actually set the Default Gateway of routers 1 hop away and after that EIGRP routers will just know about the route but not set their default gateway.
That is a very important concept to understand for exam day!
Using a Summary-Address (the third and final way to propagate a default route)
The configuration for this is the exact same syntax to set a Summary-Address on an interface if you were doing Summarization with a bunch of sequential Prefixes, lets walk through how different routers see this:
R1(config)#int s0/0/0
R1(config-if)#ip summary-address eigrp 100 0.0.0.0 0.0.0.0
R1(config-if)#
*May 15 04:33:06.235: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 172.12.123.2 (Serial0/0/0) is resync: summary configured
*May 15 04:33:06.235: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 172.12.123.3 (Serial0/0/0) is resync: summary configured
R1(config-if)#do sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
D* 0.0.0.0/0 is a summary, 00:00:47, Null0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 172.12.123.2, 01:15:33, Serial0/0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 172.12.123.3, 01:15:33, Serial0/0/0
100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 100.100.100.0/30 is directly connected, Loopback100
L 100.100.100.2/32 is directly connected, Loopback100
172.12.0.0/16 is variably subnetted, 4 subnets, 2 masks
D 172.12.23.0/24 [90/2173416] via 172.12.123.3, 01:15:33, Serial0/0/0
[90/2173416] via 172.12.123.2, 01:15:33, Serial0/0/0
D 172.12.34.0/24 [90/2172416] via 172.12.123.3, 00:27:19, Serial0/0/0
C 172.12.123.0/24 is directly connected, Serial0/0/0
L 172.12.123.1/32 is directly connected, Serial0/0/0
R1(config-if)#
ASR#3
[Resuming connection 3 to r3 … ]
*Mar 31 23:25:50.317: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.1 (Serial0/2) is resync: peer graceful-restart
R3(config-router)#do sh ip route
Gateway of last resort is 172.12.123.1 to network 0.0.0.0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/156160] via 172.12.23.2, 02:31:09, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback3
172.12.0.0/24 is subnetted, 3 subnets
C 172.12.34.0 is directly connected, FastEthernet0/1
C 172.12.23.0 is directly connected, FastEthernet0/0
C 172.12.123.0 is directly connected, Serial0/2
D* 0.0.0.0/0 [90/2681856] via 172.12.123.1, 00:01:10, Serial0/2
R3(config-router)#
ASR#4
[Resuming connection 4 to r4 … ]
R4(config-router)#do sh ip route
Gateway of last resort is 172.12.34.3 to network 0.0.0.0
D* 0.0.0.0/0 [90/2684416] via 172.12.34.3, 00:01:43, FastEthernet0/1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/158720] via 172.12.34.3, 00:28:14, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.34.3, 00:28:14, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback4
172.12.0.0/16 is variably subnetted, 4 subnets, 2 masks
D 172.12.23.0/24 [90/30720] via 172.12.34.3, 00:28:14, FastEthernet0/1
C 172.12.34.0/24 is directly connected, FastEthernet0/1
L 172.12.34.4/32 is directly connected, FastEthernet0/1
D 172.12.123.0/24
[90/2172416] via 172.12.34.3, 00:28:14, FastEthernet0/1
R4(config-router)#
There is a lot to note and I’m getting mentally exhaust, so I will bullet point style what I’d like to point out from the above output
- The command is “ip summary-address eigrp (AS #) 0.0.0.0 0.0.0.0”
- It creates a default route on the router it is issued on
- This will “eat up” and Prefixes that were being advertised, almost turning the downstream router receiving this default route into a Stub
- R4 did get and set the default route to its next hop R3, who then has a default route to R1 who is advertising this, so it propagates all the way through the network
So, I also highlighted in red that R3 only knows of 2.2.2.2 via the Ethernet segment, which I am betting is where R4 is getting all its route as well, so I will shut down that interface to see if R3 and R4 are only left with default routes leading back to R1:
R3(config-router)#int fa0/0
R3(config-if)#shut
R3(config-if)#
*Mar 31 23:35:29.386: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.23.2 (FastEthernet0/0) is down: interface down
R3(config-if)#
*Mar 31 23:35:31.377: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Mar 31 23:35:32.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R3(config-if)#do sh ip route
Gateway of last resort is 172.12.123.1 to network 0.0.0.0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback3
172.12.0.0/24 is subnetted, 2 subnets
C 172.12.34.0 is directly connected, FastEthernet0/1
C 172.12.123.0 is directly connected, Serial0/2
D* 0.0.0.0/0 [90/2681856] via 172.12.123.1, 00:00:14, Serial0/2
R3(config-if)#
ASR#4
[Resuming connection 4 to r4 … ]
R4(config-router)#do sh ip route
Gateway of last resort is 172.12.34.3 to network 0.0.0.0
D* 0.0.0.0/0 [90/2684416] via 172.12.34.3, 00:00:23, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/156160] via 172.12.34.3, 00:36:33, FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback4
172.12.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.12.34.0/24 is directly connected, FastEthernet0/1
L 172.12.34.4/32 is directly connected, FastEthernet0/1
D 172.12.123.0/24
[90/2172416] via 172.12.34.3, 00:36:33, FastEthernet0/1
R4(config-router)#
So that demonstrates that if you set a Summary-Address as the default route, any downstream routers (without another way to learn routes like R3’s Ethernet segment) will have their routes Summarized into a default route, essentially making all EIGRP routes off that interfaces like Stub Routers as they will only learn 0.0.0.0/0 via EIGRP.
However one important thing to note, in the Topology table they don’t have the Summary-Address AD of 5, they have an Internal Route AD of 90, as also seen here:
R4(config-router)#do sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via “eigrp 100”, distance 90, metric 2684416, candidate default path, type internal
Redistributing via eigrp 100
Last update from 172.12.34.3 on FastEthernet0/1, 00:07:23 ago
Routing Descriptor Blocks:
* 172.12.34.3, from 172.12.34.3, 00:07:23 ago, via FastEthernet0/1
Route metric is 2684416, traffic share count is 1
Total delay is 40100 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2
R4(config-router)#
That is a very important note for exam day, that Default Summary-Addresses in EIGRP have an AD of 90, while an actual Summary of Prefixes advertised the same way will have an AD of 5 on downstream routers!
To verify default routes you can either view “sh ip route” and look for the * in the route table indicating the candidate default route, or “sh ip route eigrp 0.0.0.0/0” or whatever prefix is the default route being advertised.
So that will do it for tonight, I just wanted to be as clear as possible the behaviors of how the different methods propagate static routes, so that the correct method can be chosen on exam day and on the job when the network calls for an EIGRP default route.
It seems (on 15.1(4)), that when configuring redistribution of static routes, you may
configure route-map to constrain what routes may be redistributed, thus get rid of
the following concern mentioned in the text:
“So needless to say this is not ideal, unless your objective is to redistribute all static routes on exam day, but in the real world you probably don’t want new IP route statements accidentally being propagated throughout the EIGRP network.”
R1:
router eigrp 10
network 10.0.0.128 0.0.0.3
redistribute static route-map STATIC
!
ip route 0.0.0.0 0.0.0.0 Null0
ip route 192.168.0.0 255.255.255.0 Null0
!
ip access-list standard ACL_STATIC
permit 0.0.0.0
deny any
!
route-map STATIC permit 10
match ip address ACL_STATIC
!
R2:
R@#show ip route eigrp 10 | b Gateway
Gateway of last resort is 10.0.0.129 to network 0.0.0.0
D*EX 0.0.0.0/0 [170/28160] via 10.0.0.129, 00:32:36, FastEthernet0/0
R2#
Without the route map:
R1#show run | s router eigrp 10
router eigrp 10
network 10.0.0.128 0.0.0.3
redistribute static
R1#show run | i ip route
ip route 0.0.0.0 0.0.0.0 Null0
ip route 192.168.0.0 255.255.255.0 Null0
R1#
R1#sho ip route static | b Gateway
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S* 0.0.0.0/0 is directly connected, Null0
S 192.168.0.0/24 is directly connected, Null0
R1#
R2#show ip route eigrp 10 | b Gateway
Gateway of last resort is 10.0.0.129 to network 0.0.0.0
D*EX 0.0.0.0/0 [170/28160] via 10.0.0.129, 00:02:38, FastEthernet0/0
D EX 192.168.0.0/24 [170/28160] via 10.0.0.129, 00:02:38, FastEthernet0/0
R2#
LikeLike
Thank you for catching this! I am unable to immediately edit this, but I will get this updated, I appreciate you keeping the information in my notes accurate! 🙂
LikeLike