3_rtr_direct_connection

So I must preface this by saying it is the most beautiful day MN has seen in weeks, the sun is out and it’s probably mid-high 20’s, so it is the perfect day to open the shadows to let the sun in and sit in front of the command line! Ran out and got some Chipotle for later, my double shot Mocha for now, lets do this.

So I am going to do the 1 way distribution into the EIGRP domain, and I’m fairly certain be successful with filtering routes at this point, but I would like to understand the “in / out” option in the distribute-list command. It says of course incoming or outgoing routing updates, but what does incoming mean?

Everything is a blank slate at this point aside from the Topology seen above, so I am going to first configure the summary route 100.0.0.0 /13 on R3, and then we are going to DISSECT this ‘in / out’

So starting a new on each router, here we go, starting with R3:

R3(config)#no router eigrp 100
R3(config)#router eigrp 100
R3(config-router)#no auto
R3(config-router)#network 172.12.13.0 0.0.0.255
R3(config-router)#network 3.3.3.3 0.0.0.255
R3(config-router)#network 33.33.33.3 0.0.0.255
R3(config-router)#network 100.1.0.0 0.0.255.255
R3(config-router)#network 100.2.0.0 0.0.255.255
R3(config-router)#network 100.3.0.0 0.0.255.255
R3(config-router)#network 100.4.0.0 0.0.255.255
R3(config-router)#network 100.5.0.0 0.0.255.255
R3(config-router)#network 100.6.0.0 0.0.255.255
R3(config-router)#network 100.7.0.0 0.0.255.255
R3(config-router)#
R3(config-router)#int s0/2

R3(config-if)#ip summary-address eigrp 100 100.0.0.0 255.248.0.0

  • You saw that right, add network statements with WC masks, enter the summary-address statement for EIGRP on the interface it is to be advertised out with a regular subnet mask
  • To troubleshoot a network not propagating with a summary route, do “sh ip proto” to make review what networks are being routed by EIGRP, and confirm the default route itself is correct on the interface

All that aside, with R1 having no routing protocols configured, lets get to work:

R1(config)#do sh ip proto

R1(config)#router ospf 1
R1(config-router)#router eigrp 100
R1(config-router)#network 172.12.13.0 0.0.0.255
R1(config-router)#network 172.12.12.0 0.0.0.255 area 0
R1(config-router)#
*Mar  1 14:49:46.861: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.13.3 (Serial0/1) is up: new adjacency
R1(config-router)#router ospf 1
R1(config-router)#redistribute eigrp 100 metric-type 1
% Only classful networks will be redistributed <- Uhhh… what?
R1(config-router)#

As highlighted, the router is already giving me grief about some classful network warning. So the adjacency on EIGRP is up and rocking, but I have not gotten to R3 to set that up.

  • ***Metric-Types will change if Redistributed routes have the default (type 2) or the real metric (type 1)”, and “metric” is to change the AD LOCALLY ONLY – Also you need to type subnets for discontiguous networks, as will be seen down a bit when I’m troubleshooting***

Since everything is going so well, lets setup R2, and look at the routing table:

 

R2(config)#do sh ip proto
R2(config)#router ospf 1
R2(config-router)#network 172.12.12.0 0.0.0.255 area 0
R2(config-router)#network 2.2.2.0 0.0.0.255 area 2
R2(config-router)#
*Mar  1 13:20:20.451: %OSPF-5-ADJCHG: Process 1, Nbr 172.12.13.1 on Serial0/0 from LOADING to FULL, Loading Done
R2(config-router)#do sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

172.12.13.1       0   FULL/  –        00:00:37    172.12.12.1     Serial0/0

R2(config-router)#do sh ip route

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback2
172.12.0.0/24 is subnetted, 1 subnets
C       172.12.12.0 is directly connected, Serial0/0
R2(config-router)#

What now, I mean…. Time to get on R1, and troubleshoot the problem, again:

R1#show config | s router ospf 1
router ospf 1
 log-adjacency-changes
 network 172.12.12.0 0.0.0.255 area 0
R1#

It shows above that I did enter a redistribute command, but I must have gotten something wrong within it, so a step at a time again:

R1(config-router)#redistribute eigrp 100 subnets metric-type 1

R1(config-router)#
ASR#2
[Resuming connection 2 to r2 … ]

R2(config-router)#do sh ip route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback2
     100.0.0.0/13 is subnetted, 1 subnets
O E1    100.0.0.0 [110/84] via 172.12.12.1, 00:00:03, Serial0/0
     33.0.0.0/24 is subnetted, 1 subnets
O E1    33.33.33.0 [110/84] via 172.12.12.1, 00:00:03, Serial0/0
     3.0.0.0/24 is subnetted, 1 subnets
O E1    3.3.3.0 [110/84] via 172.12.12.1, 00:00:03, Serial0/0
     172.12.0.0/24 is subnetted, 2 subnets
C       172.12.12.0 is directly connected, Serial0/0
O E1    172.12.13.0 [110/84] via 172.12.12.1, 00:00:04, Serial0/0
R2(config-router)#

I highlighted the top part, as even with “no auto” configured on R1’s EIGRP config, it was still not redistributing any routes to R2 without adding ‘subnets’ onto the command, so be it. So of course you must completely remove the old statement, and re-enter it with subnets as such:

R1(config-router)#redistribute eigrp 100 subnets metric-type 1

So now that OSPF know all about EIGRP’s network and how to get their, EIGRP needs a default route back to the OSPF domain, and instead of messing around with the “ip default-network” command on R1 as it is buggy on certain IOS versions I will just drop a default route on R3 until we  get into 2-way Redistribution:

R3(config)#ip route 0.0.0.0 0.0.0.0 172.12.13.1
R3(config)#
ASR#2
[Resuming connection 2 to r2 … ]

R2(config-router)#do ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/61 ms
R2(config-router)#

Works for me! At this point I’ve actually been troubleshooting this simple topology for a couple of hours and am going into a command line coma, so I will come back later to add the distribute-list and figure out what on Earth is with the in / out portions of the statement and how they are used.

The things that we have learned or relearned here though:

  • Metric-Type affects the metric being distributed into OSPF from all other protocols, Type 2 is default metric or seed metric of 20, Type 1 is its full or true metric
  • Metric itself refers to changing the local OSPF routes metric to manually change which routes or protocols are preferred
  • Even for EIGRP with “no auto” on the ASBR, must use ‘subnets’ or routes will not propagate if they are discontiguous
  • No matter what I type on here the I have learned can never be re-learned enough, simple mistakes are easy to make, and always need to check your work starting from the easiest config working your way to the hardest part of the configuration

I will ‘wr mem’ these to keep them where they are at, I need a basic topology to play with the Distribute-List command, and understand the in / out function specificially. Got a few more videos to watch as well about 2 way redistribution.